Server issues affecting the Qwilr app
Incident Report for Qwilr
Resolved
The server issue has been resolved.
Posted 3 months ago. Jun 10, 2019 - 14:01 AEST
Investigating
It looks like we're currently having some server issues and we're investigating the cause. You may see errors loading the app or slow load times.
Posted 3 months ago. Jun 10, 2019 - 12:44 AEST
This incident affected: Qwilr App.